HOME / Network機材Tips / ルータ / IX2015

Date: 2017/08/24 |  このエントリーをはてなブックマークに追加  |  Tags: NEC IX2015

IX2015について

どういうワケか、以前、ここでふれただけなのに、検索でヒットしてくるので、一応まとめておこうとおもった。最近(2008年初頭)は、ちょうどリリースしてから3年ぐらいたち、保守切れ、リースアップっぽいものが、オークションでIX2015が流れてくるので、ソレで拾う人が多いのであろう。

IX2015は、乱暴に簡単に言うと、こんなルータである。

  • ローエンド帯の業務用ルータ
  • CISCO IOS似の設定
  • まあRTX1100とかよりちょっと速いかなという程度

IX2000系にデフォルトでちょこっとインターフェースがつき、IPsecのライセンスが投入されている程度。

まあ、こう書くと、お仕事でやってる人が、自宅とか、ノードに使うにはたしかによさそうではあるのだが、こういうデメリットもある。

  • 個人では保守に入れない。
  • 保守に入らないと、そもそも新ファームがもらえない
  • 業務用のルータにはありがちだが、ソフトの一部はライセンスを買う形式である(でも全部はいってたっけ?)。
  • マニュアルは、付属のCDROMにPDFとして入っている。インターネット上にはないので、オークションで買うときは、何とかCDROMを手に入れること(笑

などなど。

個人的に利用した感じでは、

  • RTX1000とのIPsecは20Mbpsぐらいは出た。
    • RTX1000の頭打ちかと思われる
  • RTX1000のリプレースをねらっていたので、RTX1000の変態設定はできない。
    • PPTPとか、足に複数IPつけてルーティングとか、LAN1のHUB4つでルーティングするとか・・・・
  • VLANはほとんどくめない。
  • 1度も暴走したことなかった。

まあつまり、

  • 3足のルータ。
  • 速度はそこそこしっかりしてる
  • ちゃんと使えば安定してる。
  • IPSecでそこそこ速い

と言う感じなので、普通に使えば、良いルータだと思う。保守に入れないので、そこだけは気にしておく必要があると思う。

設定例

その1。まあ普通っぽい、PPPoEの設定

いまは貸し出し中で手元にないので、昔のものをHDDから拝借。うごかないかもね。

下記、passwordの*****には、BINHEXのHashが入ります。長さからして、あんまり堅牢な暗号ではないでしょう。

hostname gw2.justplayer.com
timezone +09 00
username administrator password hash ****** administrator
logging buffered 4096
logging subsystem all error
!logging subsystem all notice
logging timestamp timeofday
terminal length  512
event-terminal start

!
!syslog facility user
!syslog host 192.168.1.5
!
ip route default FastEthernet0/0.1
ip route 192.168.1.0/24 192.168.2.253
!ip route 172.31.33.0/24 172.31.12.254 
!ip route 192.168.2.0/24 172.31.12.254 
ip access-list telnet_set permit ip src 192.168.2.253/32 dest any
ip access-list napt_host permit ip src 192.168.0.0/16 dest any
!
arp auto-refresh
!
!
proxy-dns ip enable
proxy-dns server 203.141.128.34
proxy-dns server 203.141.128.33
!
telnet-server ip enable
telnet-server ip access-list telnet_set
!

ip dhcp profile guestnet
  dns-server 192.168.2.254
  assignable-range 192.168.2.129 192.168.2.158
  exit
ip dhcp enable

ppp profile interlink
  authentication myname プロバイダのユーザ名
  authentication password プロバイダのユーザ名 パスワード
 
interface FastEthernet0/0.1
  encapsulation pppoe
  auto-connect
  ppp binding interlink
  ip unnumbered FastEthernet0/1.0
  ip tcp adjust-mss 1414
  ip napt enable
  ip napt inside list napt_host
!  ip napt service ssh 192.168.1.5 none tcp 22
  no shutdown

interface FastEthernet0/1.0
  ip address 219.117.221.49/28 
!  ip napt enable
!  ip napt inside list napt_host
!  ip napt service ssh 192.168.1.5 none tcp 22
  no shutdown

!
interface FastEthernet1/0.0
  ip address 192.168.2.254/24 
  ip ufs-cache enable
  ip dhcp binding guestnet
  no shutdown

!
interface Loopback0.0
  ip address 127.0.0.1/32 
!
interface Null0.0
  no ip address
  exit

設定例2。IPSecのノード設定

ノードの外側のIPは172.31.33.1/24で、センターは172.31.12.1/24である。この間はL2で繋がっており、RTX1000とIPSECのVPNを張った。

速度は20Mbpsぐらいでたかな。

このルータにはたしかipv6トンネルや、ipv4-ipipv4トンネルとかもあるので、そう言うのが対抗でできればいいかなーとおもったんだけど。

hostname gw.node.justplayer.com                                                                         
timezone +09 00                                                                                         
username administrator password hash ****** administrator                                         
logging buffered 4096                                                                                   
logging subsystem eth error                                                                             
logging timestamp timeofday                                                                             
arp auto-refresh                                                                                        
event-terminal start                                                                                    
!                                                                                                       
!syslog host 192.168.1.5                                                                                
!                                                                                                       
!ip route default FastEthernet0/1.1                                                                     
ip route 172.31.00.0/16 172.31.33.254                                                                   
ip route 192.168.1.0/24 172.31.33.254                                                                   
ip access-list telnet_set permit ip src 192.168.0.0/16 dest any                                         
ip access-list ipsec_host permit ip src 192.168.2.0/24 dest 192.168.1.0/24                              
ike policy ike-policy peer 172.31.12.1 key ひみちゅ   
ipsec autokey-map ipsec-policy ipsec_host peer 172.31.12.1                                              
!                                                                                                       
!                                                                                                       
proxy-dns ip enable                                                                                     
proxy-dns server 192.168.1.1                                                                            
proxy-dns server 192.168.1.3                                                                            
proxy-dns server 192.168.1.5                                                                            
!                                                                                                       
telnet-server ip enable                                                                                 
telnet-server ip access-list telnet_set                                                                 
!                                                                                                       
interface FastEthernet1/0.0                                                                             
  ip address 192.168.2.254/24                                                                           
  ip ufs-cache enable                                                                                   
  ip dhcp binding nodenet                                                        
  no shutdown                                                                                           
!                                                                                                       
interface FastEthernet0/0.0                                                                             
  ip address 172.31.33.1/24                                                                             
  ip ufs-cache enable                                                                                   
  ipsec policy tunnel ipsec-policy out                                                                  
  no shutdown                                                                                           
                                                                                                        
ip dhcp profile nodenet                                                                              
  assignable-range 192.168.2.100 192.168.2.200                                                          
  subnet-mask 255.255.255.0                                                                             

私のIX2015は、ここに貸し出し中なのであるが・・・


Network機材Tips/ルータ

Recent Updates

ディスクの不良を確認する(iostat -EnのError等)

ディスク関係のスタックをざっくり書くと次の様になっています 例、SAS Expanderを使う場合、 例、AHCIなどを使う場合、 これらのエラーは、次の様なコマンドで知ることができます。 出力結果例 このなかで、 たとえば、SATAディスクを利用している際に負荷が上がってしまい、ディスクの応答が間に合わないシチュエーションでは、Transport Errorが一気に …
»続きを読む

2017年、新年明けまして、おめでとうございます。

日記/2017年、新年明けまして、おめでとうございます。

新年明けまして、おめでとうございます。今年もよろしくお願いします。 昨年中は、皆様にお世話になりました。 昨年は、コツコツと3年程前から行ってきた改革がある程度完成された年で、この先5年、10年を見据えて、次のフェーズへと進む為の土台が完成した年でもありました。 それにキャッチアップする形で、個々の従業員一同が、役割を自覚し、明確に動けた年であったかと考えています。 …
»続きを読む

RSA鍵認証のみにし、Password認証を無効化する

意外に覚えきれなくて、いつも忘れるので、メモついでに残しておきます。 古いOpenSSHや、SunSSHの場合は、これも無効にします。 ユーザ目線でのザックリとした説明を。OpenSSHではなく別のSSH実装も含めて考えているので、OpenSSHのソースをじっくり読んだわけではないため、間違ってたらすみません。 まず、Password認証を無効にする場合、 PasswordAut …
»続きを読む

Nexus7 2013をMarshmallow(Android 6.0)化

OTAでない方法で。 だいたい ここに書いてある方法 なんだけど、adbなどが一式使えている状態で。 まずは自分の機種のものをダウンロードする。僕のは、 Android 6.0 Marshmallow for Nexus 7 2013 Wi-Fi 。tgzを展開し、zipも解いておく。 まずはboot loaderへ。 bootloader自体のアップデート。一式、updat …
»続きを読む

OS X 10.11 El Capitanで、phpのモジュールインストール

Yosemiteからのアップデートは割と簡単です。なぜならYosemite時に、すでにapache 2.4になり、php 5.5になっているから(笑 アップデート前に、まずはphp.iniとhttpd.confをバックアップしておきましょう きになるなら、hostsとかapache以下全てをバックアップしておいてもいいかも。 後はEl Capitanにアップデートする。 アッ …
»続きを読む

EasyAcc Powerbank PB4000CB

スマフォTips/モバイルバッテリー/モバイルバッテリー製品レビュー/EasyAcc Powerbank PB4000CB

薄型のモバイルバッテリーEasyAcc Powerbank PB4000CBです。 今や、モバイルバッテリーは大型のものが好まれるのか、隙間無く商品があります。20,000mAh越えで、「でけえ!」とか言ってますけど、大きいのを探せば、100Wh(27,000mAh)、200Wh当たり前、探せば500Wh(135,000mAh)とか、もっともっとあるのです。用途がどんどん異なっていくので …
»続きを読む

EC Technology Sports Headsets S10-JWH07B

デバイスTips/Bluetooth/EC Technology Sports Headsets S10-JWH07B

Bluetoothのスポーツヘッドセット、 S10-JWH07B について。 今までブログに記載することはなかったのですが、実は割とBluetoothと言うか無線型のヘッドフォンを沢山持っています。赤外線や独自物、Bluetoothなどいくつもストックを持っていたりします。普通の人からするとマニアです。でも、マニアからみるとそうでもないレベルです。 ただ「ヘッドフォンの音質」というの …
»続きを読む

静岡県内をVPNでつなぐ(割と特殊な例)

静岡というのはある意味特殊な土地で、ほとんどのインターネットプロバイダのPOIは静岡でつながれておらず、NTT西圏内のどこかで繋がっているので、大抵大阪折り返しになる。仮に静岡県内にPOIがあっても、だいたい静岡でルーティングしてないので、やっぱり東京折り返しになってたりする。例え 同じプロバイダを使っていたとしても 。 だから静岡←→静岡のVPNは、静岡←→東京や、静岡←→大阪よりも遅 …
»続きを読む

最新  |  << 前ページ  |  次ページ >>  |  最初